Category Archives: osCommerce

osCommerce 2.3.3.2 Released

osCommerce 2.3.3.3 was released today. The new version includes PHP 5.5 compatibility and several minor new features.

More information is available in the release announcement.

Posted in osCommerce | Leave a comment

osCommerce 2.3.3.1 Released

osCommerce 2.3.3.1 was released on Tuesday. The new version includes a security fix and several bug fixes.

More information is available in the release announcement.

Posted in osCommerce, Security Update | Leave a comment

osCommerce 2.3.3 Released

osCommerce 2.3.3 was released yesterday. The new version includes bug fixes and some new features.

More information is available in the release announcement.

Posted in osCommerce | Leave a comment

osCommerce 2.3.2 Released

osCommerce 2.3.2 was released yesterday. The new version “improves the customer password forgotten routine and generation of random strings”.

More information is available in the release announcement.

Posted in osCommerce, Security Update | Leave a comment

osCommerce 3.0.2 Released

osCommerce 3.0.1 was released on Saturday. The release includes “bug fixes, framework improvements, and introduction of new Applications”. The new admin applications are Categories, Customers, and Services.

More information is available in the release announcement.

Posted in osCommerce | Leave a comment

osCommerce 3.0.1 Released

osCommerce 3.0.1 was released on Friday. The release includes bug fixes and improvements. In certain server environments the automatic upgrade feature will not correctly upgrade from 3.0 to 3.0.1, this bug has been fixed in 3.0.1.

More information is available in the release announcement .

Posted in osCommerce | Leave a comment

osCommerce 3.0 Released

osCommerce 3.0 was released last Friday. This release is a complete rewrite of the software based on a new framework.  The new framework will “allow customizations to be easily applied”. The new version requires that templates and add-ons be rewritten. A tool for migrating a stores data from older versions is planned to be ready towards the end of the month. According to the release announcement it does “not contain a complete base feature set to start running an online shop on” and that the base feature set will available during April.

The new release increases the system requirements. You now need at least version 5.3 of PHP (with PDO MySQL extension), PHP 5.3 is not widely supported by hosting providers yet, and at least MySQL v4.1.13 or v5.0.7.

Posted in osCommerce | Leave a comment